Page 1 of 2

Combat the black plane bug

PostPosted: 29 Aug 2014, 11:07
by Lionhardt
I have found a workaround for the black plane bug. So, if you are encountering it just drill an itsy bitsy "drain hole" into the outer most rim of your map. The black plane will span across the deepest points with the same value of you map. Thus it will be only inside the drain hole.

From now on make sure you build your maps high enough so that you have room downwards for this emergency solution.

btw. sticky? That might save a lot of new mappers tons of frustration.

Spoiler: show
drainhole.jpg
drainhole.jpg (157.53 KiB) Viewed 4255 times

Re: Combat the black plane bug

PostPosted: 29 Aug 2014, 11:32
by Aurion
Might wanna explain what kind of bug you're talking about for the less experienced mappers (like me), because I don't know, especially if this needs to be stickied. Nice to find a solution though, if it kinda breaks the looks of your map.

Re: Combat the black plane bug

PostPosted: 29 Aug 2014, 12:13
by Lionhardt
It is a common bug that so far the only solution was "avoid at any costs!". It happens when you cross a certain border value of the height difference between highest on lowest point of the map. Sometimes you got lucky because of some unkown parameters that were different and the bug didn't appear even though the difference would we too large already normally. When you have world borders enabled ingame you then get a black plane over your map as described above.

Re: Combat the black plane bug

PostPosted: 29 Aug 2014, 12:28
by Plasma_Wolf
I have helped one person with this bug once, the point was that his height difference was way too high. My maps don't have a height of more than 60 and I never have the black plane bug. The person I helped out, had a height of over 150. I simply halved this and the bug was gone. The heightmaps usually don't need a difference of more than 60 anyway.

I really can't remember a moment where the bug popped up at a random point.

Re: Combat the black plane bug

PostPosted: 29 Aug 2014, 12:30
by Lionhardt
That is what I said. And with this workaround you no longer need to adjust your heightmap. The max height difference on this map is is 51 btw. and the bug came anyway.

Re: Combat the black plane bug

PostPosted: 29 Aug 2014, 14:05
by Krapougnak
I build all my maps with a base height of 70 and never have the black plane bug again isn't this solution much easier to implement than yours ? (just asking no disrespect intended here)

Re: Combat the black plane bug

PostPosted: 29 Aug 2014, 14:54
by Lionhardt
Well, mine is meant as an emergency solution... as I already said. When you already HAVE the bug and want to fix it without much work.


...I never new setting the height to 70 will spare you the bug in the fist place, anyway.

Re: Combat the black plane bug

PostPosted: 30 Aug 2014, 08:14
by Krapougnak
Lionhardt wrote:Well, mine is meant as an emergency solution... as I already said. When you already HAVE the bug and want to fix it without much work.


...I never new setting the height to 70 will spare you the bug in the fist place, anyway.



Yeah I did some testing to see at what basic height the black plane would disapear and I found 70 to be the ideal number and it is not very far away from the basic height the editor gives the map when you create it (around 65 if I remember).

But yes indeed your workaround solution will help for already done maps, good find ! :)

Re: Combat the black plane bug

PostPosted: 31 Jul 2016, 21:18
by Smokamrok
I vote for making this post sticky, this really helped me with my maps, no more crappy looking water ;)
So pls someone stick it to the front page.

Re: Combat the black plane bug

PostPosted: 01 Aug 2016, 05:29
by biass
well now that you necroed it will be on front page for another year or so