[SOLVED]Formations log errors

Everything about mods can be found here.

Moderator: Morax

[SOLVED]Formations log errors

Postby Mavr390 » 18 Jun 2020, 21:40

Hi all!!!
I get this error regularly in the logs:
Code: Select all
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=13, formation slots=13)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=13, formation slots=13)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=12, formation slots=12)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=12, formation slots=12)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=13, formation slots=13)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=13, formation slots=13)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=8, formation slots=8)
warning: Failed to assaign unit xsl0304 a slot in the formation AttackFormation (units=8, formation slots=8)

only the unit id changes. How to fix it?
P.S. I did not make changes to formations.lua.
Last edited by Mavr390 on 29 Jun 2020, 19:49, edited 1 time in total.
Mavr390
Crusader
 
Posts: 18
Joined: 26 Oct 2019, 07:54
Has liked: 6 times
Been liked: 0 time
FAF User Name: Mavr390

Re: Formations log errors

Postby Sprouto » 18 Jun 2020, 22:34

Most formation errors such as this one are caused by an unexpected or missing category in the unit blueprint - which causes the formation code to fail when it tries to find a spot for this particular unit. Debugging the formation code is a rather difficult exercise - but I would suggest trying this manually - cycling thru the different formations with the same set of selected units - with the intention of at least discovering which formation is throwing this problem.
Sprouto
Priest
 
Posts: 354
Joined: 08 Sep 2012, 05:40
Has liked: 54 times
Been liked: 73 times
FAF User Name: Sprouto

Re: Formations log errors

Postby Mavr390 » 18 Jun 2020, 23:20

Sprouto, thanks for the quick response))
The problem is that it is the xsl0304 that appears in 98% of errors. If I do not set the SERAPHIM fraction for AI, then this error appears extremely rarely.
Mavr390
Crusader
 
Posts: 18
Joined: 26 Oct 2019, 07:54
Has liked: 6 times
Been liked: 0 time
FAF User Name: Mavr390

Re: Formations log errors

Postby Mavr390 » 29 Jun 2020, 19:49

Sprouto wrote:Most formation errors such as this one are caused by an unexpected or missing category in the unit blueprint - which causes the formation code to fail when it tries to find a spot for this particular unit. Debugging the formation code is a rather difficult exercise - but I would suggest trying this manually - cycling thru the different formations with the same set of selected units - with the intention of at least discovering which formation is throwing this problem.

Sprouto, you were right. These errors really appeared due to missing or unnecessary categories in the unit's blueprints.
After making changes to the found units, the errors disappeared.
Thanx!!! Great Thanx!!!!
Mavr390
Crusader
 
Posts: 18
Joined: 26 Oct 2019, 07:54
Has liked: 6 times
Been liked: 0 time
FAF User Name: Mavr390


Return to Mods & Tools

Who is online

Users browsing this forum: No registered users and 1 guest