Page 1 of 2

A couple major bugs I've found

PostPosted: 29 Jan 2017, 05:46
by Hobbyte
Hey guys, I love this mod, fits really well with the base game, and feels to me like a second expansion! :D

I've noticed a couple bugs that are pretty major and borderline game-breaking.

First: with BlackOps ACU mod, the commander seems to have lost his overcharge damage resistance. This means that with BlackOps ACU, a commander can basically be oneshotted with an overcharge. In vanilla, they seem to have some huge resistance like (80% less damage taken from overcharge)

Second: when a commander is told to "ASSIST" a building that is upgrading (shield gen, factory, etc..) rather than help it upgrade like an engineer would, he wants to go out and fight units nearby like a tank would. This may be related to #1, perhaps the commander is being "tagged" as a "military unit" rather than an "ACU" unit.

Are these mods on github? I do have some experience with lua, some minor experience with Supcom modding, and am a programmer by trade... I'd be willing to take a stab at fixing these bugs if someone can point me to the repo and maybe a little documentation about modding!

Thanks guys!

EDIT: Another super annoying issue I've found is that building hotkeys on commanders don't work

Re: A couple major bugs I've found

PostPosted: 05 Feb 2017, 21:48
by IceDreamer
I've checked these over. OC is fine, armour works correctly. Assist thing will be fixed next release. Not sure what hotkeys you mean, all of hotbuild works fine.

Re: A couple major bugs I've found

PostPosted: 17 Feb 2017, 10:19
by Hobbyte
Hey thanks so much for taking a look at this, I apologize for taking so long to get back to you. Here's some more info for you.

I'm testing with:
BlackOps FAF: ACUs v12
BlackOps FAF: Unleashed v12
Map: Winter Duel

No other mods.

Here's what I mean about hotkeys:
In "build mode" with an engineer it looks like:
In "build mode" with a commander it looks like:

Notice the lack of hotkey letters, and pressing the keys also doesn't work.

As for the overcharge issue:
In vanilla: before overcharge: and after 3 overcharges:
In BlackOps: before overcharge: and after one overcharge: (nuked him)

Re: A couple major bugs I've found

PostPosted: 17 Feb 2017, 18:48
by PhilipJFry
I'm not an expert but i couldn't find any commander class armor in the armordefinition.lua in blackops so i guess thats causing the issue.

edit: i simply copied the armor for acus from the FAF github to blackops and now it works fine for me.
Spoiler: show
Code: Select all
{   # Armor Type Name

        # Armor Definition
        'Normal 1.0',
        'Overcharge 0.03333',
        'Deathnuke 1.0',

location for the armor type file: C:\Users\"your user"\Documents\my games\Gas Powered Games\Supreme Commander Forged Alliance\Mods\BlackOpsFAF-Unleashed\hook\lua

Re: A couple major bugs I've found

PostPosted: 23 Feb 2017, 16:54
by IceDreamer
Build mode won't work with custom units like BlackOps ACUs. Use the main game hotkeys instead (Hotbuild), they're better anyway...

Re: A couple major bugs I've found

PostPosted: 31 May 2017, 22:38
by Armada115
Hi, sorry to add to this but i've found a bug or 2.

I run
BlackOps FAF: ACUs v12
BlackOps FAF: Unleashed v12

i've come across when upgrading the Aeon Commander chest upto the Teleporting, you lose the UI to him.
UEF commanders Nuke becomes unusable after a Cut sense or a few shots to the point where it just wont fire.

Re: A couple major bugs I've found

PostPosted: 31 May 2017, 23:40
by CSI
Oh yeah I remember having the same issue

Coop bugs

PostPosted: 09 Jun 2017, 23:34
by Ares37901
So the bugs I am having are to do with Coop Campaign on FAF.

I tested the bugs with any combination of mods, The Blackops ACUs on its own as well.
Whenever you upgrade the weapons, they work. Until one of the following happens:
ACU build any structure
ACU teleport
ACU gets on transport
Sometimes when goes underwater, not sure on this one, kept getting distracted and couldn't catch this one with my eyes.
After one of the above, the guns stop working. All of them, engineering hand guns, standard hand guns, backpack weapons (both aa and any artillery system).

If the upgrades are removed and applied again, then they work but until one of the above occurs again. Two of my friends experienced the same issue.
The other systems work as intended, resources, all the different effect fields etc. So the problem occurs with weapons ONLY, but every weapon.

The feeling is as if the code, that dictates the weapons are there, goes poof whenever one of the above actions occur. Would really appreciate if you could look into this, my take is that something in the Coop itself breaks the mods. Question is if it can be fixed to work on both or does a different copy with amended functionality will have to be put in place.

Re: A couple major bugs I've found

PostPosted: 11 Jun 2017, 23:20
by IceDreamer
Don't know, and I'm extremely lacking time. I'll look if/when I can.

Re: A couple major bugs I've found

PostPosted: 21 Jun 2017, 09:17
For people suffering from the acu to acu overcharge bug, make sure your armordefinitions.lua file in Mods\BlackOpsFAF-Unleashed\hook\lua looks like this:

armordefinition = {
{ -- Armor Type Name

-- Armor Definition
'Normal 1.0',
'Overcharge 0.066666',
'Deathnuke 0.032',
'Fire 2.5',
{Armor Type Name
Armor Definition
'Normal 1.0',
'Overcharge 0.1',
'Deathnuke 1.0',

Turns out the v12 of blackops unleashed in the vault is missing the second part.