Can't Create or Join Match

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Can't Create or Join Match

Postby Pelius » 08 Nov 2019, 04:08

I can't create or join a match. I have reinstalled and restarted things. Everything else on the client appears to work fine. When I try to join or create a game the notification portion at the bottom of the FAF client says, 'Preparing game: Reading file list' and then 'Preparing game: Downloading ForgedAlliance.exe'. If there is any other file I need to upload or attach please let me know. Thanks!

EDIT: I have tried other solutions on the forums. I have allowed Downlord's FAF Client all the permissions and deactivated Windows Defender to see if that was blocking FAF. It didn't change anything. So it doesn't look like a permissions issue from my computer. I am the only one using my router and the only one with the password and it is not a college based internet.

EDIT: I checked my router and disabled the firewall there as well and tested FAF client, still unable to create or join game.

Ok now I feel I had SupCom installed on steam from way way way long ago. I got a new computer and was like, let's join FAF. I followed all the instructions, but I didn't run FAF on steam. One final file needed to be downloaded before the game ran. So I solved my own problem after taking the long way around. Yeah!
(50.91 KiB) Downloaded 28 times
(79.36 KiB) Downloaded 22 times
Posts: 1
Joined: 08 Nov 2019, 03:59
Has liked: 0 time
Been liked: 0 time
FAF User Name: Pelius

Return to Tech Support

Who is online

Users browsing this forum: No registered users and 1 guest