Missing .dll files in new install [SOLVED]

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Missing .dll files in new install

Postby Sir Prize » 05 Nov 2019, 01:53

Hi, I'm trying to set up FAF on my laptop, and I get two error messages about missing .dll files every time I try to launch from the .exe file in the bin folder or host a test game or replay from the python client, images below.
ImageImage
The java client just doesn't launch a replay/lobby when I try to watch a replay or host a test, just downloads a replay then briefly prepares file list then reads game files then nothing.

I've cleared game data, uninstalled and reinstalled both FAF clients and the game itself (which meant a 5GB re-download from Steam lol) and can't shake these error messages. Send halp plz TIA (or just share the .dll files I'm missing with me and tell me where to put them...?)
Attachments
downlords-faf-client.log
(9.55 KiB) Downloaded 3 times
forever.log
(49.06 KiB) Downloaded 4 times
User avatar
Sir Prize
Evaluator
 
Posts: 540
Joined: 24 May 2014, 10:29
Has liked: 61 times
Been liked: 87 times
FAF User Name: PREVED-MEDVED

Re: Missing .dll files in new install  [SOLVED]

Postby PhilipJFry » 05 Nov 2019, 08:48

have you tried running the game via steam before running it via faf?
the missing dll files are probably for the directx9 and steam installs that stuff upon running the game for the first time
cats>dogs
post logs
User avatar
PhilipJFry
Moderator
 
Posts: 2375
Joined: 23 Mar 2016, 21:16
Location: Austria
Has liked: 218 times
Been liked: 338 times
FAF User Name: PhilipJFry


Return to Tech Support

Who is online

Users browsing this forum: PhilipJFry and 1 guest