Page 1 of 1

Can't get FAF client to run at all

PostPosted: 13 Feb 2019, 21:47
by servoRat64
Did a search and read though FAQ and support thread but couldn't find anything. I've downloaded it from <redacted faforever URL> run the installer which appears to work just fine, but when I launch downlords-faf-client.exe I just get some java related error:


---------------------------
downlords-faf-client.exe - Entry Point Not Found
---------------------------
The procedure entry point JVM_GetNestMembers could not be located in the dynamic link library C:\Program Files\Java\jdk-11.0.2\bin\java.dll.
---------------------------
OK
---------------------------

The .exe is still running so I have to kill it in task manager. I tried installing the latest JDK but it didn't help. I am (unfortunately) on Win10. Any help would be appreciated.

Re: Can't get FAF client to run at all

PostPosted: 13 Feb 2019, 23:45
by Geosearchef
How the heck did that happen?

The client ships its own JRE which it should be using. I don't know why it doesn't. The Java version you need to run the client is 10.

Re: Can't get FAF client to run at all

PostPosted: 14 Feb 2019, 01:34
by servoRat64
Cool, I've added the bundled java bin directory to my %PATH% in front of the java11 bin directory and it all seems to be working now. Not the most elegant solution, but I don't think it's going to break anything else.

So for some reason, the faf .exe is looking for a java.dll in the %PATH% environment variable before it looks in the bundled directory.