Connection issues with 2 people in the same LAN

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Moderator: PhilipJFry

Re: Forged Alliance Logs

Postby egamruf » 27 Oct 2018, 03:29

Geosearchef wrote:We moved the test server. The file is currently located at . You will have to change the server settings on the login page by double clicking the faf logo till I create a new build, we're currently testing the python client.
Change server port from 18001 - > 8001, remove the port from the last link (API) and change it from http - > https.

Instead you can also try the python client release .


OK, so trying the java client. First, cancel connection. 18001 became 8001. API lost everything after (and including) the colon, and became https. 15001 remained as it was. I then logged in as 'me'. When I go to host a game it doesn't allow me to select a game type, which prevents me from hosting games.

Were we doing something wrong here?


In any event we've reverted to using the Python 0.26 beta client build. Is there a reason you suggest using FAF Develop as the game mode? Connecting seemed to function with standard FAF (we tried both) - is it less stable with the beta front end somehow? Does FAF Develop incorporate something we need/should have, that FAF doesn't?

When we did a disconnect/reconnect test for the people on LAN (using FAF Develop, if that makes a difference), only one of them reconnected - that is:
1. A & B are on LAN, C is in another location;
2. A hosts game, B and C join;
3. B pulled out network cable, disconnecting from internet;
4. game declared connection issue and started counter;
5. B reinserted network cable and reconnected to C; and
6. A and B never reconnected.

Is this a known ICE problem for LAN clients (reconnection won't function)?
Posts: 8
Joined: 06 Oct 2018, 17:26
Has liked: 0 time
Been liked: 0 time
FAF User Name: egamruf

Re: Connection issues with 2 people in the same LAN

Postby Geosearchef » 27 Oct 2018, 10:23

No, as far as I can tell you're not doing anything wrong, IRC port should be 15000 afaik but that shouldn't matter too much.

You being unable to select a game type indicates there was an error when communicating with the API, which is probably due to the API not running on the server ;), someone was busy testing the replay server. I've now started it, but I'd recommend testing on the test server (, which the python client connects to by default), not the java test server ( as I am currently blocking other people from testing there due to ICE testing anyways 8-) . I'm aiming to run serveral tests per week there now as ICE seems to be working pretty well.

The reason to use FAFDevelop is that there are simply no game files to be patched on the java test server. The normal test server used by the pyton cient build just cheats by telling you to get your game files from the production server ;), so you can use anyone of them.

Most of the features are working quite well, most issues are down to problems with archtitecture integration. The one you have noticed about reconnecting (I know about that one) is probably due to the python server failing to forward some of the ICE related messages. I hope to get the fixed in the next days.

In theory reconnect should always work when you have an internet connection (as the server needs to forward a small message between both adapters containing info how they can reach each other, even if they are in one network).

I've also created a tutorial on how to join an ICE test game: viewtopic.php?f=45&t=16844
Developer, Server Admin, ICE, currently working on Team Matchmaking, FAF Client
User avatar
Posts: 392
Joined: 18 Oct 2013, 14:08
Location: Germany
Has liked: 6 times
Been liked: 127 times
FAF User Name: Geosearchef

Re: Connection issues with 2 people in the same LAN

Postby egamruf » 28 Oct 2018, 08:27

Given the effort to get everyone to switch to the python beta, we'll probably just stick with that for now. Played a 4 v 4 game last night - no obvious issues FYI, all players in Australia.

Tried to watch the replay today - replay doesn't seem to work. I assume this is a known issue too?
Posts: 8
Joined: 06 Oct 2018, 17:26
Has liked: 0 time
Been liked: 0 time
FAF User Name: egamruf


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 1 guest