Various mouse and controls related glitches

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Moderator: DukeOfEarl

Various mouse and controls related glitches

Postby HerzogGorky » 06 Feb 2019, 17:06

For the last couple of months i've been experiencing something wierd behaviour related to mouse and cursor. Only thing i found on forums is some old "UI lag" thread and im not sure if its the same problem or not as it is described really vague there.

Here's a list of things that are not working properly for me which appear periodically and dont saty for too long but are quite annoying:

1. When you hover your mouse pointer over a unit, it usually shows these four thingies on each corner of its hitbox, representing that if you lift-click it will be selected. However in my case that sometimes break. I point somewhere around the middle of a unit and these four little shits don't appear and left clicking does nothing. Then if i try moving my cursor a little bit over a unit or a little bit under it, they show up and i can select it, but that is also not true 100% of the time.
Here i was like okay, i can just use box selection when it happens, its not too often, right?

2. No, box selection sometimes doesn't work too. I hold my left mouse button, drag it and nothing. At this point i have to say that my mouse works perfectly in any other game/program/OS i tried. I also tried changing mouses and this bug happens with all 3 of them.
I should also mention that i started to notice all the bugs when i bought mouse #2 as my mouse #1 was a little bit laggy. Mouse #2 had double-click problem and i stopped using it, so i switched back to mouse #1. Then i realised all these weird stuff going on wasn't related to mouse #2 not working perfectly but something of another nature. So i bought mouse #3 as my mouse #1 was still laggy, and as mouse #3 works just fine everywhere other than supcom, where none of 3 work like i want. This all might be just a coincidence, and i didn't try to remove mouse #2 drivers.

3. Placing a building. Sometimes when i choose to build a structure, i press my hotkey and a blueprient appears on cursor, then i point somewhere on the map and the bluepring goes green, indicating that this place is suitable for placement. However when i left click it doesnt give the order and the blueprint continues to follow my arrow pointer. It appears to depend on the location, because if it happens no matter how much i click it wont ever give an order on that spot until i reselect the structure or drag the order from somewhere else. But the blueprint is not red and i can still place structures on the same spot if i just reselect it.

4. Switching order types. Alt+right click always works fine. But repair/reclaim/move orders sometimes break. I will try to describe how painful it is to reclaim trees:
I press hotkey for move order. It works. I place order and press hotkey for reclaim order. It works, i select some trees, press move hotkey again. Lets assume it breaks now.
Mouse pointer icon doesnt change, i press on desired spot and it selects trees for reclaim instead. I press move hotkey again, it doesnt work. I cancel wrong order and press move hotkey, it doesnt work. I am like screw this i will just not put any move orders. I press reclaim hotkey because of a habit. It switches to a move order. I press on trees and it gives a move order. I press reclaim key again, it doesn't work. I press move key, it changes to reclaim mode. i rage. Same with repair. Didn't try out using UI buttons to change order type.

Btw i am only able to reproduce all these in a multiplayer game. Singeplayer works fine even if i create lobby from faf and start solo. My port is open and i have public connection in downlord's. I also almost never loose a connection to other player(s). As i cant reproduce in single i will post logs when i play a game and make sure that i notice any of these bugs, but i believe all of my latest games have them. For the same reason it takes some time to test any ways of fixing.

I already switched from borderless 2 screen setup to single screen, where i tried fullscreen, windowed and borderless(ahk script from forums) modes. Tried changing all graphics options. I don't think my cpu or gpu (intel and nvidia btw if it matters) are bottlenecking and even if they do all of these bugs can appear right at the start of the game. I have the most fresh gpu drivers, which were updated 3 times since it all started so its not the case either. My OS is windiws 10, all the scaling options are turned off. I also didn't try to reinstall the game as im too lazy (yeah writing this forum post prolly took me more time, but i still had to play once to test it). Plz halp!
HerzogGorky
Crusader
 
Posts: 14
Joined: 20 Jan 2018, 21:42
Has liked: 0 time
Been liked: 1 time
FAF User Name: HerzogGorky

Re: Various mouse and controls related glitches

Postby ZOB » 07 Feb 2019, 06:39

3rd party mouse (and trackpad) drivers are often garbage, try the default microsoft mouse driver and remove 3rd party ones
ZOB
Avatar-of-War
 
Posts: 99
Joined: 12 Jan 2012, 12:15
Has liked: 2 times
Been liked: 8 times

Re: Various mouse and controls related glitches

Postby HerzogGorky » 09 Feb 2019, 23:40

So i finally managed not to forget to save the log so here it is.

I don't think it could help, but on somewhere on minute 7 i selected reclaim order and arrow pointer started flickering rapidly between reclaim icon and normal icon not letting me to select things for reclaim. Maybe i can catch that on video if it helps.
Attachments
game.log
(375.83 KiB) Downloaded 6 times
HerzogGorky
Crusader
 
Posts: 14
Joined: 20 Jan 2018, 21:42
Has liked: 0 time
Been liked: 1 time
FAF User Name: HerzogGorky

Re: Various mouse and controls related glitches

Postby HerzogGorky » 09 Feb 2019, 23:41

ZOB wrote:3rd party mouse (and trackpad) drivers are often garbage, try the default microsoft mouse driver and remove 3rd party ones

Now giving it a second thought i believe these are actually wireless adapter drivers, not drivers for mouse itself.
HerzogGorky
Crusader
 
Posts: 14
Joined: 20 Jan 2018, 21:42
Has liked: 0 time
Been liked: 1 time
FAF User Name: HerzogGorky

Re: Various mouse and controls related glitches

Postby ZLO_RD » 10 Feb 2019, 10:26

1) sounds like you are playing in a windowed mode, if that is the case and that glich happens try stretching windows a tiny bit in any way and this should get fixed.
2,3 - not sure what to say
4) sounds like the same issue when you don't need precise click for attack move but do need them for repair or reclaim.

about this glich... sometimes from the beginning, sometimes when you move windows around (and especially when you snap it to sides of the screen, handy function of windows 7 8 10) your cursor in game gets offsed down by the size (widht) of the window-top-bar.
do you use a 2k or 4k monitor? on 1080p monitor this problem makes game unplayeble, but maybe on higher resolution you don't notice it as much...
i wanted to replicate a problem and make a screenshot but it only appears on my second monitor (720p) atm and i don't see cursor on screenshot, i wanted to record a video but OBS records my cursor as if i am actually poiting a unit while i do point below it... weird.
http://www.youtube.com/user/dimatularus
http://www.twitch.tv/zlo_rd
TA4Life: "At the very least we are not slaves to the UI"
User avatar
ZLO_RD
Supreme Commander
 
Posts: 2098
Joined: 27 Oct 2011, 13:57
Location: Russia, Tula
Has liked: 275 times
Been liked: 344 times
FAF User Name: ZLO

Re: Various mouse and controls related glitches

Postby HerzogGorky » 10 Feb 2019, 20:06

So yes as i said at some point i tried switching to fullscreen mode and the game behaves exaclty the same. I understand what glitch you are talking about like the actual cursor position and the arrow on screen are not in sync and the second one is lower, however again its not the case. For me it rather appears like something is blocking the cursor from selecting the unit exaclty in the centre. At the same time i can move the mouse to ANY hitbox egde (slightly higher than centre or slightly lower or left/right).

About reclaim/repair orders. If my mouse was just offset it still could place the orders on the ground or other object. So i don't MISS with the orders, i cannot place them. In one of the cases the cursor icon is rapidly changing from reclaim to normal and back again like 20 times per second and it just counts as regular clicks. In the other case it cannot be selected at all.

I made i picture to illustrate my problem better. Red area shows where you need to put your pointer so that it changes to a plus in a circle, 4 thingies appear on the corner of a unit and it can be selected. Strategic view icons dont work for selection as well. Selection box works fine (when it works) without any offsets. I repeat again - it only glitches in multiplayer
Attachments
glitch.png
glitch.png (15.66 KiB) Viewed 103 times
HerzogGorky
Crusader
 
Posts: 14
Joined: 20 Jan 2018, 21:42
Has liked: 0 time
Been liked: 1 time
FAF User Name: HerzogGorky

Re: Various mouse and controls related glitches

Postby HerzogGorky » 12 Feb 2019, 23:05

Today i tried full clean reinstall and that did not solve any issues.
HerzogGorky
Crusader
 
Posts: 14
Joined: 20 Jan 2018, 21:42
Has liked: 0 time
Been liked: 1 time
FAF User Name: HerzogGorky

Re: Various mouse and controls related glitches

Postby Uveso » 14 Feb 2019, 22:03

As programmer i see a wrong mouse/gfx offset.

Could be caused by the windows desktop scaling.

Just a try, but can you set the Windows scale / layout to 100% ?

See 2nd settings picture:
https://www.pcworld.com/article/2953978/displays/use-windows-10s-individual-display-scaling-to-perfect-your-multi-monitor-setup.html
User avatar
Uveso
Supreme Commander
 
Posts: 1338
Joined: 11 Dec 2015, 20:56
Location: Germany
Has liked: 46 times
Been liked: 193 times
FAF User Name: Uveso

Re: Various mouse and controls related glitches

Postby HerzogGorky » 15 Feb 2019, 16:21

It's already 100%. Not really sure how this could cause mouse flickering and only appear in multiplayer
HerzogGorky
Crusader
 
Posts: 14
Joined: 20 Jan 2018, 21:42
Has liked: 0 time
Been liked: 1 time
FAF User Name: HerzogGorky


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 1 guest