Gray screen stuck (D3D9 Device lost)

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Moderator: DukeOfEarl

Gray screen stuck (D3D9 Device lost)

Postby Cyrax » 08 Jul 2018, 14:10

Hello everyone.

Since last few weeks (actually I didn't play before for a long time), time to time during the game my screen turns into gray, completely freezes, then it kinda minimizes and restores again. For whole thing it takes like 5-6 seconds, and I can't do nothing to it.

It looks very similar to if video driver were crashed and then restored. But I never had this before with my current config (top xps 13 2017) and I really didn't change anything with drivers and system (cept spring windows update, but it was like month or two before).

I decided that it could be some of faf addons crashing driver and tried to turn all them off, and for the first time it seemed to help. But, clever guy will try to find which one of addons cause actual problem and for me it seemed to be BetterReclaimView v1 (modified by some dude on forum to overlay lower reclaim by higher one). I turned it off and let others stay, and voilà, no window refreshments... for one day. On the next day I've just stuck on gray screen with no refreshment, and if I kill supcom process - whole system hangs and I've left nothing to, but manually reboot pc. And this crap repeated to me over and over again, I even tried to turn off win notifications (they are silent on background, but I thought that could confuse system if one happens) and installed latest win update - no result.

I'm thinking about to wipe all game's cache, but I don't want loose my game data, unless I'm 100% sure that this will help.


logs of latest crashed game:

debug: Current gametime: 00:03:30
debug: Loading module '\000/projectiles/tifnapalmcarpetbomb01/tifnapalmcarpetbomb01_script.lua\000'
debug: Loading module '\000/units/uel0104/uel0104_script.lua\000'
debug: Loading module '\000/units/ueb0103/ueb0103_script.lua\000'
warning: c:\work\rts\main\code\src\libs\gpggal\DeviceD3D9.cpp(937) Device lost
debug: Loading module '\000/units/xsl0104/xsl0104_script.lua\000'
Cyrax
 
Posts: 8
Joined: 23 Sep 2017, 22:01
Has liked: 1 time
Been liked: 1 time
FAF User Name: Cyrax

Re: Gray screen stuck (D3D9 Device lost)

Postby Uveso » 08 Jul 2018, 18:39

All your game data and settings are saved in the file:
"C:\Users\YOUR_USER_NAME\AppData\Local\Gas Powered Games\Supreme Commander Forged Alliance\Game.prefs"

Just save the "Game.prefs" file.
User avatar
Uveso
Supreme Commander
 
Posts: 1095
Joined: 11 Dec 2015, 20:56
Location: Germany
Has liked: 38 times
Been liked: 161 times
FAF User Name: Uveso


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 1 guest