running on linux |uncaught exception [SOLVED]

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Moderator: DukeOfEarl

running on linux |uncaught exception

Postby artur453 » 04 Jun 2018, 23:49

I followed this instruction to install Faf:https://wiki.faforever.com/index.php?title=Setting_Up_FAF_Linux#Install_using_steam
when i click on game i get "FA has failed to start " and then"uncauht exception! "
this window contain:
Spoiler: show
Code: Select all
Traceback (most recent call last):
  File "/home/Games/client-0.16.1/src/games/_gameswidget.py", line 276, in gameDoubleClicked
    self.client.join_game(uid=game.uid)
  File "/home/Games/client-0.16.1/src/client/_clientwindow.py", line 1270, in join_game
    self.game_session.listen()
  File "/home/Games/client-0.16.1/src/fa/game_session.py", line 90, in listen
    assert self.state == GameSessionState.OFF
AssertionError

Spoiler: show
// /home/Games folder contain client-0.16.1 folder
i can sure that SU:Fa on PoL installed correctly

What i can do with this?
artur453
 
Posts: 4
Joined: 08 Apr 2018, 20:56
Has liked: 0 time
Been liked: 0 time
FAF User Name: artur453

Re: running on linux |uncaught exception

Postby Wesmania » 05 Jun 2018, 00:50

It sounds like you didn't setup your client to use wine correctly. Check the 'Client setup' section at https://wiki.faforever.com/index.php?ti ... _FAF_Linux. Also test if you can run the ForgedAlliance.exe at ~/FAForever/bin with your wine. The exception is a long-standing bug that I ought to fix, but it's harmless.
FAF python client dev. You client misbehaves? Pester me.
Wesmania
Priest
 
Posts: 315
Joined: 19 Nov 2014, 19:17
Has liked: 1 time
Been liked: 52 times
FAF User Name: MazorNoob

Re: running on linux |uncaught exception  [SOLVED]

Postby artur453 » 12 Jun 2018, 00:06

I many times reinstall client and SU:FA,and wine(PoL) and Googling
i understand problem in instruction :
"cmd_prefix=primusrun <- prefix the program start for something like switchable graphics"
primus -techonology to run some on nvidia videocart,if it nvidia+intel pc(mostly notebooks)
that`s not for all users!!!PLS fix it //in my case all graphic runs by nvidia
when i eraserd "cmd_prefix=primusrun" from config file,i understand that`s i many times installed all correctly and get ...
Supreme commander famous error connected with mesh.fx
https://appdb.winehq.org/objectManager. ... n&iId=9728

p.s and fix client (version)/src/util/__init__.py 104 line
PERSONAL_DIR.encode("ascii") i manualy need change to PERSONAL_DIR.encode("utf-8")
p.p.s sorry for my bad english
artur453
 
Posts: 4
Joined: 08 Apr 2018, 20:56
Has liked: 0 time
Been liked: 0 time
FAF User Name: artur453


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 1 guest