When weapons don't fire

Post here if you want to help developing something for FAF.

When weapons don't fire

Postby stardust » 01 Jul 2018, 18:52

Here's a good one for the crowd. I can't seem to figure this out. For my little personal naval units project, I have three assets I've borrowed that don't seem to work.

BRPT1ADVNAVYGUN makes the firing noise but that's it. Nothing else happens. No fire and no damage on a hostile target.

URB2306 is supposed to be some sort of beam defense tower, but just sits there. Doesn't fire or do anything. No sound either.

ERS0302 is a frigate with a beam cannon and SAM launcher. The beam has a muzzle flash, impact effect and firing sound effect, but no actual beam. And I can find no reference to the weapon pointing to a projectile or effect.

Can anyone shed some light on this? Much obliged, thanks!
Attachments
ERS0302_unit.bp
(27.58 KiB) Downloaded 45 times
URB2306_unit.bp
(9.26 KiB) Downloaded 45 times
BRPT1ADVNAVYGUN_unit.bp
(7.73 KiB) Downloaded 39 times
User avatar
stardust
Avatar-of-War
 
Posts: 53
Joined: 23 May 2018, 01:25
Location: Canada, eh.
Has liked: 3 times
Been liked: 0 time
FAF User Name: stardust2101

Re: When weapons don't fire

Postby Uveso » 02 Jul 2018, 01:07

Hello Stardust,

well this is a bit complicated. To test/debug this units we need the unit folder with script an model files.

(Even with those data is maybe not possible to debug because you have linked some weapons to custom files inside your mod.)
User avatar
Uveso
Supreme Commander
 
Posts: 1230
Joined: 11 Dec 2015, 20:56
Location: Germany
Has liked: 45 times
Been liked: 186 times
FAF User Name: Uveso

Re: When weapons don't fire

Postby stardust » 02 Jul 2018, 17:27

Shucks, I was afraid of that.

Okay, the forum won't let me attach all files, so here are some dropbox links.

BRPT1:
https://www.dropbox.com/sh/dbncy9xl6zvi ... qTt2a?dl=0

ERS0302:
https://www.dropbox.com/sh/ia63lkshuoob ... EQOGa?dl=0

URB2306:
https://www.dropbox.com/sh/g58jbhmw3jga ... J20Fa?dl=0

Appreciate the assist!
User avatar
stardust
Avatar-of-War
 
Posts: 53
Joined: 23 May 2018, 01:25
Location: Canada, eh.
Has liked: 3 times
Been liked: 0 time
FAF User Name: stardust2101

Re: When weapons don't fire

Postby Uveso » 20 Jul 2018, 22:18

Hello stardust,

looks like i missed your last post :(

Is this solved, or do you still need help with this ?
User avatar
Uveso
Supreme Commander
 
Posts: 1230
Joined: 11 Dec 2015, 20:56
Location: Germany
Has liked: 45 times
Been liked: 186 times
FAF User Name: Uveso

Re: When weapons don't fire

Postby stardust » 21 Jul 2018, 16:14

Still stuck with this, thanks Uveso :)
User avatar
stardust
Avatar-of-War
 
Posts: 53
Joined: 23 May 2018, 01:25
Location: Canada, eh.
Has liked: 3 times
Been liked: 0 time
FAF User Name: stardust2101

Re: When weapons don't fire

Postby Uveso » 22 Jul 2018, 22:36

Hello Stardust,

i am sorry, but i can't debug those units.
The first error i got was:

Code: Select all
Unable to find file /mods/naval unit pack 1.0/hook/cybranweapons.lua

Without all corresponding files i can't run the unit-scripts.

I guess you have to move this at the end of your ToDo list.
User avatar
Uveso
Supreme Commander
 
Posts: 1230
Joined: 11 Dec 2015, 20:56
Location: Germany
Has liked: 45 times
Been liked: 186 times
FAF User Name: Uveso

Re: When weapons don't fire

Postby stardust » 23 Jul 2018, 01:42

Uhh, that's strange, because it's there. The lua file, that is. And if memory serves, it's the stock one from the core game, unless I grabbed it from somewhere else...
User avatar
stardust
Avatar-of-War
 
Posts: 53
Joined: 23 May 2018, 01:25
Location: Canada, eh.
Has liked: 3 times
Been liked: 0 time
FAF User Name: stardust2101

Re: When weapons don't fire

Postby Franck83 » 23 Jul 2018, 02:31

Maybe the rep name is not regular ?
'../naval unit pack 1.0/..'
Alliance of Heroes Mod is out ! Try it ! It's in the Mod Vault !
User avatar
Franck83
Priest
 
Posts: 414
Joined: 30 Dec 2016, 11:59
Location: France
Has liked: 71 times
Been liked: 78 times
FAF User Name: Franck

Re: When weapons don't fire

Postby Uveso » 23 Jul 2018, 06:03

I guess in this case it's the cybranweapons.lua from black ops.
But without the file from inside /naval unit pack 1.0/hook/ i can't debug.

For deeper debugging we need the whole mod folder with everything in it.
But because of copyright issues we can't upload the complete mod public.
User avatar
Uveso
Supreme Commander
 
Posts: 1230
Joined: 11 Dec 2015, 20:56
Location: Germany
Has liked: 45 times
Been liked: 186 times
FAF User Name: Uveso

Re: When weapons don't fire

Postby stardust » 23 Jul 2018, 13:20

Uveso, I sent you a PM.

On a different but similar tack, I was playing with the Orbital Wars Reborn mod and noticed that none of the big spaceships and some of the fighters don't fire at anything, no matter what. I took a look at the game code but didn't see anything jump out at me. Unless there was something with the layers? I'd really like to get it working, if possible, as it looks like it's been abandoned by the creator.
User avatar
stardust
Avatar-of-War
 
Posts: 53
Joined: 23 May 2018, 01:25
Location: Canada, eh.
Has liked: 3 times
Been liked: 0 time
FAF User Name: stardust2101

Next

Return to Contributors

Who is online

Users browsing this forum: No registered users and 1 guest