Page 1 of 1

Game time running very slowly

PostPosted: 02 Oct 2018, 09:26
by Mirci
Every second in the game last 6+ seconds of real time, so it's like playing in slow motion. It's weird because FPS moves around 20 to 100 based on zoom and action, so FPS doesn't seem to be critical to influencing in-game time.
GPU never go over 50% and CPU has one core used to nearly 100% while remaining cores run on average under 10%. So I thought the issue is with the game not using more than one core, but then I was reading in other topics on this forum that this game can't use more than one core. My CPU is running over 4.5GHz and I experienced this issue in 1v1 game with only over 200 units.
I would understand some issues in 4v4 with 1000 units, but not in 1v1 with very few units. And I've also tried to lower the graphics settings to minimum and resolution as well, but there was no difference.
Any ideas on how to make the game playable?

Re: Game time running very slowly

PostPosted: 02 Oct 2018, 17:28
by Uveso
Hello Mirci,

welcome to FAForever!

We can only guess, but your game can be slower because:

-There are too many errors in your gamelog.
(We will know if you send us your game.log. See red text above "Read this before posting here" for more information.

-Your antivirus is scanning files and your harddrive is busy.
(Is your harddrive working all the time ?)

-Your harddrive is dieing.
(not a joke, please check your harddrive for errors)

-Your soundcard is not set to stereo.
(can cause error spam in game.log)

-You are using Wi-Fi
(Use a cable)

-Your internet connection is to slow.
(well..)

Re: Game time running very slowly

PostPosted: 03 Oct 2018, 05:56
by Mirci
Thanks for replay.

I can't figure out how to get that game.log. I checked all the settings and game files, but couldn't find it. Neither detailed guide here at FAF.

I probably didn't mention quite an important thing that I played that 1v1 only with a bot. I haven't played this game since I played the campaign years ago, so I wanted to train a little and I also don't want to play online if the game isn't running properly.

I was thinking that I may not see the option for game.log in settings because I may not have the latest version of the game. So I bought the steam version, but still no sign of game.log. Anyway reinstalling the game to latest update may fix this issue and I guess I should do that before starting a new thread (apologies). I'll post the update once I properly test the updated version of the game.

I don't have an antivirus, even windows defender is switched off. I have multiple different drives, the oldest SSD seems like dieing, but I had it on HDDs in raid 0 and now installed it to my most recent drive Samsung 950 Pro to be safe. Soundcard (Xonar STX) is set to stereo as I have stereo speakers. I'm connected through a cable and my internet is 200/10mb, even though I had this issue offline, so it shouldn't be relevant.

Update: Tested it and I'm nearly two hundreds of units and one second in the game is two of real-time. The only hardware that is used to max power is first core on CPU.

Re: Game time running very slowly

PostPosted: 03 Oct 2018, 18:14
by Katharsas
What is your hardware? Especially, CPU, memory and if you know it mainboard?

Re: Game time running very slowly

PostPosted: 04 Oct 2018, 12:25
by ZLO_RD
how much CPU score lobby shows?
what actual sim speed you get in game? -3 or -8 or it does not show like that?

Re: Game time running very slowly

PostPosted: 05 Oct 2018, 13:54
by Mirci
CPU: AMD FX-9590
Memory: Corsair 16GB (2x 8GB) PC2400 CL11 Vengeance Pro
MB: ASRock 990FX Extreme6
GPU: Vega 64

I'm not sure how I can find that score of CPU in a lobby. When I tried to join a random lobby the CPU score wasn't showing. That sim speed isn't showing with numbers. Simply I timed 10 seconds in the game, which was more than a minute of real-time.
I just tried to play online and it wasn't as bad, so it seems like this issue is related to bots.

Re: Game time running very slowly

PostPosted: 06 Oct 2018, 00:27
by Katharsas
Please check your CPU temperature while in the game. Maybe your cooler is mounted badly or something.

Re: Game time running very slowly

PostPosted: 10 Oct 2018, 12:19
by Mirci
Temperature margin while playing is over 40 degrees Celsius. But you right that this CPU is a nightmare to cool it down. It's not possible to run a stability test that uses all 8 cores to 100%. And in the last summer, my PC occasionally crashed while I played a high demanding game during the daytime since the room temperature was around 30s. But I don't think I can really improve my cooling and I took a good care to install it properly. I have Noctua NH-D15 (with a drop of Noctua paste and witch second fan slightly higher cause of high coolers on memory) and the case is Fractal Design Define R5 with 140 large Noctua fans running at full speed (one in the front, one in the back, plus one slower 120 at front's bottom for HDDs).

Anyway, I think that this issue is generally about the game when there are bots in it. The AI is just too demanding and the game is not able to use more than one core, so then it slows itself down to avoid any lags. I guess I just have to avoid playing with bots on the big maps and when I played online without bots it seemed mostly OK.

Image

Re: Game time running very slowly

PostPosted: 10 Oct 2018, 13:18
by Anihilnine
need log

Re: Game time running very slowly

PostPosted: 11 Oct 2018, 09:20
by Mirci