Page 8 of 8

Re: Collection of current bugs

PostPosted: 26 Dec 2017, 21:09
by AIx_Putin
faf client still not correctly workin with high dpi settings - got all fonts not fill space correctly. same issue with games list and so on.
http://clip2net.com/s/3QFrHEi
p.s. 200% font\icon size set in display properties

Re: Collection of current bugs

PostPosted: 28 Dec 2017, 16:30
by AIx_Putin
also faf client suffer of issues with game client size. if u use any other size than 100% in display properties - when u alt tab from game\lobby ur cursor is hidden and faf client run in full screen mode

Re: Collection of current bugs

PostPosted: 21 May 2018, 08:17
by lakimakromedia
Hi, I have installed lately beta version. In some games i have such problem:
Code: Select all
java.util.concurrent.CompletionException: java.lang.IllegalStateException: Can't initialize connection when connectivity state is unknown
   at java.util.concurrent.CompletableFuture.encodeThrowable(Unknown Source)
   at java.util.concurrent.CompletableFuture.completeThrowable(Unknown Source)
   at java.util.concurrent.CompletableFuture.uniRun(Unknown Source)
   at java.util.concurrent.CompletableFuture$UniRun.tryFire(Unknown Source)
   at java.util.concurrent.CompletableFuture.postComplete(Unknown Source)
   at java.util.concurrent.CompletableFuture.complete(Unknown Source)
   at com.faforever.client.task.CompletableTask.lambda$new$2(CompletableTask.java:18)
   at com.sun.javafx.event.CompositeEventHandler.dispatchBubblingEvent(CompositeEventHandler.java:86)
   at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:238)
   at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:191)
   at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:58)
   at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
   at com.sun.javafx.event.EventUtil.fireEventImpl(EventUtil.java:74)
   at com.sun.javafx.event.EventUtil.fireEvent(EventUtil.java:54)
   at javafx.event.Event.fireEvent(Event.java:198)
   at javafx.concurrent.EventHelper.fireEvent(EventHelper.java:219)
   at javafx.concurrent.Task.fireEvent(Task.java:1356)
   at javafx.concurrent.Task.setState(Task.java:723)
   at javafx.concurrent.Task$TaskCallable.lambda$call$501(Task.java:1434)
   at com.sun.javafx.application.PlatformImpl.lambda$null$172(PlatformImpl.java:295)
   at java.security.AccessController.doPrivileged(Native Method)
   at com.sun.javafx.application.PlatformImpl.lambda$runLater$173(PlatformImpl.java:294)
   at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
   at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
   at com.sun.glass.ui.win.WinApplication.lambda$null$147(WinApplication.java:177)
   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalStateException: Can't initialize connection when connectivity state is unknown
   at com.faforever.client.connectivity.ConnectivityServiceImpl.connect(ConnectivityServiceImpl.java:278)
   ... 24 more

Java reistalled. FAF no yet.
My another problem is that, the game crashes during loading, and I'm unable to close it by Program Manager - only loguot or restart pc :/.
Cant report it:
https://imgur.com/a/QLjWl35

Re: Collection of current bugs

PostPosted: 24 May 2018, 14:38
by Typo91
-some players are only able to connect in gamelobby when restarting faf multiple times


any idea what causes this? I've recently upgraded to windows 10 from windows 7.... Same exact problem...

Only thing I can think of... is my router?

ps... I have noticed if someone trys to join a game, the moment I do... I will never connect unless I end task and try again...
Does this mean its trying to look for x players to connect with before the +1? seems to always not work if someone else joins the same moment i am joining.

Re: Collection of current bugs

PostPosted: 03 Jun 2018, 13:56
by SilentWarrior
Hi,

I've been experiencing some UI problems when in-game.
The problem I have noticed is when I move my mouse pointer away from the centre of the screen. The pointer changes it's image from the regular SupCom one to that of the ordinary mouse pointer in windows.
This prevents any further selection or instructions to be made. I have to move the pointer back towards the middle then zoom in and out then into the area I wish to send my units to, to make instructions.
Upon further studying of the problem, I have noticed a certain patch middle right, where if the mouse passes through, it changes between the two pointer modes.
The strange thing is, I just went to record this in obs and bang the problem disappeared. Frustrating.

Initially, I thought it was the mouse itself, I changed the mouse. Then I thought it might be my really old keyboard, I bought a new one. I even reinstalled the mouse drivers and SupCom. I tried to use Downlords client, but the problem is the same.
I have now only have two mods installed. The common tools mod and the selection depriortizer mod 4.1

Maybe I have something wrong with my settings or it's a windows thing. I don't know.

Can anyone shed some light on what the problem may be?

Many thanks,

Re: Collection of current bugs

PostPosted: 03 Jun 2018, 13:59
by speed2
Do you use fullscreen? Try windowed

Re: Collection of current bugs

PostPosted: 16 Jun 2018, 12:48
by SilentWarrior
speed2 wrote:Do you use fullscreen? Try windowed


Yes, this worked.

The problem now was the ugly windows borders and the Windows Taskbar. I downloaded some program to remove that for me. Unfortunately, you have to run the software everytime, which meant once the game starts, then you would instruct the FullScreener which screen to make full.
This was a little annoying, especially if you want to play ladder.

This is how I solved the Full-Screen problem;

Someone had told me to reinstall the game. Tried that, didn't work.
Someone told me to reinstall faf. Tried that, didn't work.

After Uninstalling faf, I noticed that faf folders were still there in my windows Program files (x86). So I manually deleted the whole folder C:\ProgramData\FAForever\
Reinstalled faf and then opened and updated it.

It worked :D

So, what I'm trying to say is, something inside the faf directories themselves was causing the problem and not my operating system or some configuration I may have had on my desktop pc.
I don't know what that something is, but I'd thought I'd share.

Re: Collection of current bugs

PostPosted: 16 Sep 2018, 00:17
by Farmsletje
When watching a game from obs pov you can't use the minimap to jump to another location. When selecting a players pov it works again.

Re: Collection of current bugs

PostPosted: 16 Sep 2018, 01:47
by QuestionMarkNoob
Disconnects in-game introduce very strong FPS- and a minor amount of UI-lag. FPS drops can reach from a minor annoyance to making the game unplayable. Also discussed here: viewtopic.php?f=2&t=16654
It does not seem like I am the only one with said problem.