Connectivity Issues

This is for troubleshooting of problems with the FAF client and Forged Alliance game.

Connectivity Issues

Postby Jip » 29 Aug 2019, 11:50

Hello,

Recently I've been having some connectivity issues. This happens primarily during the game but also when trying to connect initially into a lobby.

The problem that I have is that I lose connection to (generally) one or two player(s), causing the entire game to 'wait'. In the end, we do not manage to reconnect and I therefore have to leave the game. This started quite recently, two - three weeks ago it was all good. Now, it seems to be happening every single game.

I've taken a look at: https://ping.canbeuseful.com/#ping
Generally, my ping is 100% stable. Until I start playing a FaF game. Then there are a few 200 - 400 ms spikes, which seem to relate to when I lose connection to another player. But I am unsure if this is really the case.

As far as I can see, I appear to be the sole person having these kind of troubles. Therefore it's probably related to me. I was hoping someone knows a few things I can try to improve the situation.

A lot of people in FaF tend to think my CPU may have an involvement here, I disagree. But in case it does: it's a AMD Phenom 1055T. (Yeah, I tend to get ejected for my CPU rating.)

Some other information: I tend to write my own (UI) mods. Even when all the mods are turned off, it still happens.

With kind regards,

Jip

iceadapter.log: https://pastebin.com/1gKZERkU (game A)
game.log: https://pastebin.com/0VR3ahep (game B)
downlords-faf-client.log: https://pastebin.com/Zw2MUSK6 (game B)
Last edited by Jip on 29 Aug 2019, 13:53, edited 2 times in total.
Jip
Crusader
 
Posts: 37
Joined: 12 Jul 2015, 22:25
Has liked: 3 times
Been liked: 6 times
FAF User Name: Jip

Re: Connectivity Issues

Postby Geosearchef » 29 Aug 2019, 12:45

Please take a look at the ice adapter debug window and tell us what happens there whenyou loose connection to somebody.
Developer, Server Admin, ICE, currently working on Team Matchmaking, FAF Client
User avatar
Geosearchef
Priest
 
Posts: 321
Joined: 18 Oct 2013, 14:08
Location: Germany
Has liked: 4 times
Been liked: 98 times
FAF User Name: Geosearchef

Re: Connectivity Issues

Postby Jip » 29 Aug 2019, 13:51

An Iceadapter log for a recent game, different game than the other logs: https://pastebin.com/1gKZERkU

It keeps trying to reconnect (gathering, checking, disconnected, gathering, ...).

edit: I am not sure what you want me to look for within the debug window of the ICE adapter.
Jip
Crusader
 
Posts: 37
Joined: 12 Jul 2015, 22:25
Has liked: 3 times
Been liked: 6 times
FAF User Name: Jip

Re: Connectivity Issues

Postby Jip » 08 Sep 2019, 18:38

*bump*

I am still experiencing these problems. Is there anyone that can help me?

It's always merely me that has issues with some arbitrary other player. And we generally do not reconnect afterwards.
Jip
Crusader
 
Posts: 37
Joined: 12 Jul 2015, 22:25
Has liked: 3 times
Been liked: 6 times
FAF User Name: Jip

Re: Connectivity Issues

Postby Geosearchef » 09 Sep 2019, 00:11

Can't see anything in there. It tries but doesn't succeed at connecting. I would need the stdout/stderr of the adapter. THere's currently no option for that in the client, so the only thing that would help would be a log from a client version before 0.10.6 (https://github.com/FAForever/downlords- ... .10.4-beta). (downlords-faf-client.log)

Pls pm/notify me if you reply, our zulip RSS bot sadly doesn't trigger yet on updates in existing topics.
Developer, Server Admin, ICE, currently working on Team Matchmaking, FAF Client
User avatar
Geosearchef
Priest
 
Posts: 321
Joined: 18 Oct 2013, 14:08
Location: Germany
Has liked: 4 times
Been liked: 98 times
FAF User Name: Geosearchef

Re: Connectivity Issues

Postby pchelka » 12 Sep 2019, 00:33

You are not the only one - i have exact same problem BUT in my case its random as i can play some games, but bigger ones hang just on start after map load
(i usually lost connection to ppl.)
pchelka
Crusader
 
Posts: 10
Joined: 24 Mar 2019, 17:26
Has liked: 0 time
Been liked: 0 time


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 1 guest