Games and lobby's have been very laggy for me lately

Talk about general things concerning Forged Alliance Forever.

Moderators: FtXCommando, JJ173

Games and lobby's have been very laggy for me lately

Postby dead_beat » 02 Sep 2018, 02:20

This started happening about a week ago, when I join or host a lobby it's super laggy, like im getting 5 fps and going in slow motion and games have a light but constant stutter throughout. I've never experienced lag on faf before and my pc has handled the game just fine for years. Every other game I have runs just like it used to and my internet connection is just fine, I've tried reseting everything but the lag is still there. Is anybody else experiencing this?
dead_beat
 
Posts: 2
Joined: 05 Feb 2016, 04:53
Has liked: 0 time
Been liked: 0 time
FAF User Name: dead_beat

Re: Games and lobby's have been very laggy for me lately

Postby Geosearchef » 02 Sep 2018, 10:10

Are you running on a laptop oe desktop. Which graphics card do you use?
Developer, currently working on ICE adapter, Java Client (downlords's client), java api/server.
User avatar
Geosearchef
Avatar-of-War
 
Posts: 125
Joined: 18 Oct 2013, 14:08
Location: Germany
Has liked: 1 time
Been liked: 26 times
FAF User Name: Geosearchef

Re: Games and lobby's have been very laggy for me lately

Postby Viba » 02 Sep 2018, 10:36

Does it start immediately or after some time? I've had some weird FPS issues/stuttering recently too, starts like a switch is being turned around 15-30 minutes into the game.
Viba
Moderator
 
Posts: 649
Joined: 22 Jan 2015, 21:42
Has liked: 128 times
Been liked: 199 times
FAF User Name: !smurfcheck Viba

Re: Games and lobby's have been very laggy for me lately

Postby QuestionMarkNoob » 02 Sep 2018, 15:00

Viba wrote: I've had some weird FPS issues/stuttering recently too, starts like a switch is being turned around 15-30 minutes into the game.


This is exactly what is happening to me as well. I got around 80 fps early on and a couple of minutes later, I am stuck with 25 FPS for the rest of the game.

At this point I have tried almost every suggestion on this forum and none of them helped me sadly. What I have found however, is that this game is still fairly GPU dependent when it comes to FPS.

My GPU (gtx 970 overclocked) only ran at about 860mhz all the time, even though it was under heavy use... When I fixed that by removing the FPS cap, I got slightly better FPS overall. However, this still doesn't lift the performance to the mark it once was :(

EDIT: I forgot to add, that when watching replays the performance is much better compared to actually playing the game. Though I don't know if this is normal, since I have only really started to watch replays a couple of months ago.
Creator of dual_gap_fix.v0001 - dual_gap_fix.v0004 and DualGap_fix_adaptive.v0005 - DualGap_fix_adaptive.v0007 N O T Dual Gap Adaptive v5.6 or any other versions!

PM me if you find any bugs in one of my maps.
QuestionMarkNoob
Avatar-of-War
 
Posts: 77
Joined: 02 Feb 2018, 15:55
Location: Questionmark?
Has liked: 25 times
Been liked: 9 times
FAF User Name: Thau-

Re: Games and lobby's have been very laggy for me lately

Postby Viba » 02 Sep 2018, 15:21

Finally someone else with my problem, I've tried pretty much everything already. Replays run fine for me too, game just starts having fps problems out of nowhere since a few months back.

i5 3570k @ 4.7
GTX 770
Temps are fine, clocks are steady and usage % not even high. Had no problems previously with same parts, new SSD and fresh windows installation did nothing.

In one game the fps problems started after connection screen went away and a player dropped (the replay desyncs at that point). In another game with fps problems, the replay desyncs at same time when fps problems started while playing. Could just be a coincidence, but could you try to note down when the FPS change happens and check replay for desyncs around that time? I suspect some game patch/client update is behind this.
Viba
Moderator
 
Posts: 649
Joined: 22 Jan 2015, 21:42
Has liked: 128 times
Been liked: 199 times
FAF User Name: !smurfcheck Viba

Re: Games and lobby's have been very laggy for me lately

Postby Farmsletje » 02 Sep 2018, 15:59

Since a few weeks ago i have random fps drops from around 80-90 to 5-10, which resolves itself after about half a minute
FtXCommando wrote:
need to give him some time to blossom into an aids flower
Farmsletje
Evaluator
 
Posts: 888
Joined: 14 Sep 2016, 18:38
Has liked: 283 times
Been liked: 355 times
FAF User Name: Farmsletje

Re: Games and lobby's have been very laggy for me lately

Postby Viba » 02 Sep 2018, 17:01

Ok I pretty much confirmed FPS issues are related to connectivity/replays desyncing.

Just played my third game where I noticed this clearly, replay #8499230.
At min 35 one player dropped, we got the connection screen and waited until everyone ejected him. After the connection screen went away, the FPS tanked like it has been doing. Three times can't be a coincidence now.
Haven't had time to watch replay yet if it desyncs around that time, I bet it does.

EDIT:
Watched replay, it indeed desyncs at the time when FPS in-game tanked. Replay FPS is fine though.
Image
Viba
Moderator
 
Posts: 649
Joined: 22 Jan 2015, 21:42
Has liked: 128 times
Been liked: 199 times
FAF User Name: !smurfcheck Viba

Re: Games and lobby's have been very laggy for me lately

Postby QuestionMarkNoob » 03 Sep 2018, 00:39

Hm.
I just played a couple of games and I also noticed a slight reduction in FPS after the the connection screen. Though it was only about 5 FPS and not night and day as in your case.
For me it was mostly "general" bad performance in the sense that my performance was just bad all around. Much worse that a couple of patches ago. Weird that my FPS now doesnt steeply drop to 25 anymore and does this instead now :? .
I will play some more games and see how it works out.

EDIT: Okay I played a couple more games, and I can now confirm that I have the same issue. After the connection screen my FPS drops by a lot, in both replays and games.
However I don't know why I have games where this isn't the case...
Creator of dual_gap_fix.v0001 - dual_gap_fix.v0004 and DualGap_fix_adaptive.v0005 - DualGap_fix_adaptive.v0007 N O T Dual Gap Adaptive v5.6 or any other versions!

PM me if you find any bugs in one of my maps.
QuestionMarkNoob
Avatar-of-War
 
Posts: 77
Joined: 02 Feb 2018, 15:55
Location: Questionmark?
Has liked: 25 times
Been liked: 9 times
FAF User Name: Thau-

Re: Games and lobby's have been very laggy for me lately

Postby Athena » 03 Sep 2018, 22:25

I have this same exact problem
User avatar
Athena
Crusader
 
Posts: 16
Joined: 01 Sep 2018, 17:08
Has liked: 0 time
Been liked: 12 times

Re: Games and lobby's have been very laggy for me lately

Postby Plasma_Wolf » 06 Sep 2018, 22:34

The game attached got insane connection issues right after someone disconnected. Artifax was the first person to disconnect, and right after that NUDAX had a desynch. The lag issues seemed to come from him. Or between him and one other person specifically. I did not notice any framedrops but the connection lag was so big you wouldn't notice those anyway.

I added the game log as well.
Attachments
game.uid.8516909.log
(504.95 KiB) Downloaded 20 times
8516909-Plasma_Wolf.fafreplay
(353.24 KiB) Downloaded 19 times
User avatar
Plasma_Wolf
Supreme Commander
 
Posts: 1267
Joined: 20 Oct 2011, 11:28
Has liked: 19 times
Been liked: 76 times
FAF User Name: Plasma_Wolf

Next

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 1 guest